New Here?
Toggle Content
   

Toggle Content User Info
Welcome

Anonymous

Nickname
Password
Register

Membership:
Latest: Oscarboiro
New Today: 0
New Yesterday: 0
Overall: 16556

Online Now [11]:
Visitors: 10
Bots: 1
Members: 0
Staff Online Now:

No staff members are online!
Page Views:
Today: 6175
Total: 66489209

Toggle Content Main Menu
 General Info Goodies Search Web Stats Members
 Donations

 

Forums ›

:: Forums ›
indicators 206 1.1
-> 206 Problems

#1: indicators 206 1.1 Author: maxine877, Location: UK PostPosted: Fri Apr 01, 2011 12:53 pm
    ----
hi
i am new to this forum and driving (only passed a few weeks back). i am starting to regret buying this car. when i first got the car left indicator at rear needed a new bulb. i replaced it and they seemed fine. now the indicators stay on even if the engines off. i have checked fuses and all bulbs they seem fine. i have been advised by friends to get a new fuse box for the driver side and also that its the bsi. i have been told to replace the relays. i am very confused as to what i am supposed to do with it. the other lights are fine. although the radio now works suddenly half way down the road and when you turn the key once the lights should come with the radio before you turn the key again for the engine which it doesnt anymore. please explain in lymans terms how i sort my pug out. i have only had a few weeks and really enjoy my freedom.
cheers for any brainwaves xx

#2: Re: indicators 206 1.1 Author: Lee, Location: England PostPosted: Fri Apr 01, 2011 12:55 pm
    ----
Take the stalk/Com off and see if the indicators go off

#3: Re: indicators 206 1.1 Author: maxine877, Location: UK PostPosted: Fri Apr 01, 2011 1:15 pm
    ----
ok how do i do that??

#4: Re: indicators 206 1.1 Author: Lee, Location: England PostPosted: Fri Apr 01, 2011 1:48 pm
    ----
Year of car?

#5: Re: indicators 206 1.1 Author: macca1411, Location: North West PostPosted: Fri Apr 01, 2011 1:51 pm
    ----
Welcome to the site. You're finding the joys of Peugeot electrics. Is it all your indicators or just one side?

#6: Re: indicators 206 1.1 Author: maxine877, Location: UK PostPosted: Fri Apr 01, 2011 2:34 pm
    ----
its all the indicators. 1999. but so far everyone seems to think its a electrical rather than a mechanical issue. my head hurts thinking about this car.

#7: Re: indicators 206 1.1 Author: Lee, Location: England PostPosted: Fri Apr 01, 2011 3:30 pm
    ----
Guide here, how to remove the stalk - 206info.co.uk/Forums/v...25575.html

#8: Re: indicators 206 1.1 Author: maxine877, Location: UK PostPosted: Sat Apr 02, 2011 8:27 am
    ----
hi

i followed the instructions and the stalk seems fine the lights are still too.

cheers

#9: Re: indicators 206 1.1 Author: Lee, Location: England PostPosted: Sat Apr 02, 2011 11:21 am
    ----
So the indicators still stay on with the stalk removed?

I'd go with the relay is stuck on, its inside the BSI

#10: Re: indicators 206 1.1 Author: MrBSI, Location: What's it to you? ? ? PostPosted: Sat Apr 02, 2011 11:23 am
    ----
Might be replaceable if your handy with a soldering iron.

Might be a job for BBA

Might just be a replacement BSI

#11: Re: indicators 206 1.1 Author: Lee, Location: England PostPosted: Sat Apr 02, 2011 11:26 am
    ----
Try unplugging the hazard switch as well.

But as the car is 12 years old, wouldn't surprise me if the relay has packed in.

#12: Re: indicators 206 1.1 Author: maxine877, Location: UK PostPosted: Sat Apr 02, 2011 12:26 pm
    ----
ok, so how do i fix this?? and where do i find the relay and bsi? how will i know which relay does which?
am still waiting on me haynes manual in the post. unfortunately who i bought the car off didnt have a manual or even a lot of history.
cars these days confuse me their just tooo complex. i prefer the oldies!!

#13: Re: indicators 206 1.1 Author: MrBSI, Location: What's it to you? ? ? PostPosted: Sat Apr 02, 2011 12:39 pm
    ----
maxine877 wrote:

cars these days confuse me their just tooo complex. i prefer the oldies!!

You have a simple non plexed 206, you would be even more confused if it was multiplexed Wink

#14: Re: indicators 206 1.1 Author: Lee, Location: England PostPosted: Sat Apr 02, 2011 12:40 pm
    ----
You've only been passed a few weeks, how many cars can you have had Laughing

The BSI is in the drivers fusebox, the bottom row of fuses are directly in the BSI

If you don't want to crack up the BSI, and do soldering on the circuit board, you can always rewire the indicators


Removal of the BSI from the car

- Remove the fuse box cover
- Remove the protective cover from the underside of the fusebox
- Unscrew the BSI Torx screw (Torx20) and push the retaining clip at the lower part of the fusebox (see below)
 

- Now push the BSI down, and pull it towards you
- Flip the BSI upside down:
 

- Remove the Grey (GRIS), Blue (BLEU) and Yellow (JAUNE) connector:
 

- and the Black (NOIR) and Green (VERT) connector:
 

- Open the wire binder, and remove the wires from the binder
- You should now have the BSI:
 


Removal of the relays from the BSI

- Open the BSI by pushing all retaining clip on the sides and taking the two parts apart:
 

NOTE: To remove the PCB from the cover, all connectors on the PCB have to be desoldered.
Because this is a lot of work (if not impossible) you should try to avoid it (it's not needed;).
If you're not able to remove or place the relays, you can always cut a piece of plastic out of
the cover right above the relays.

- Desolder the 5 leads of the two relays (you need the solder iron to be about 400°C)
 

- Pin 3 (indicated with green arrows) is probably the hardest pin to desolder. So desolder the other pins,
then heat pin 3 as long as needed to pull the relay from the board.
- You should now have the two relays removed from the PCB:
 


The new relay

 

The relay is the FBR51ND10-N (51ND10-N) from Fujitsu (datasheet 1Mb)
In Europe it is available through Conrad Electronic, partnumber 505102-89. (Actually the FBR51ND12-W1)
If you can't find this relay in your country, you can also use the G8QN-1C4-DC12 from Omron as a replacement (datasheet 500kb).
This relay is amongst others available through Digi-Key, partnumber Z2696-ND.
(NOTE: I haven't tried this relay myself, I choosed it based on the datasheets. So use it at your own risk.)
Placing the new relays

OK, this is quite a fiddly work, since you can't just put the relay on the PCB from the top, because of the cover.
But I managed to do it, you just need some patience.
As I said before, if it doesn't work for you, just cut a piece from the cover.
OK, now the relays are placed, you can place the BSI back in your car.
Just do the reverse of removing the BSI.

#15: Re: indicators 206 1.1 Author: maxine877, Location: UK PostPosted: Sat Apr 02, 2011 2:17 pm
    ----
right i think am gonna have to do this monday when kids are at school and the shops are open.
wish me luck

#16: Re: indicators 206 1.1 Author: macca1411, Location: North West PostPosted: Sat Apr 02, 2011 3:52 pm
    ----
You seem pretty confident with it so you shouldn't need luck. Have you already got the relay? No point dismantling till you get one. I just checked Maplin and they don't list them

#17: Re: indicators 206 1.1 Author: maxine877, Location: UK PostPosted: Wed Apr 13, 2011 3:18 pm
    ----
hiya soz i havent got back to you guys sooner. bloody kids!!!! anyway when i took the bsi off from the fuse box i discovered the black connection is corroded so its port on the bsi. what do i do now am guessing that means summit more serious??
cheers

#18: Re: indicators 206 1.1 Author: Lee, Location: England PostPosted: Wed Apr 13, 2011 3:22 pm
    ----
Electrical contact cleaner, and clean it up

#19: Re: indicators 206 1.1 Author: maxine877, Location: UK PostPosted: Wed Apr 13, 2011 3:39 pm
    ----
even if the plastic around the pins is melted??

#20: Re: indicators 206 1.1 Author: maxine877, Location: UK PostPosted: Wed Apr 13, 2011 4:11 pm
    ----
right i have just put the bsi back into the car and now its not starting. is it me or is this car just getting worse???

#21: Re: indicators 206 1.1 Author: Lee, Location: England PostPosted: Wed Apr 13, 2011 5:08 pm
    ----
Does it turn over but not fire?

Or do nothing?

#22: Re: indicators 206 1.1 Author: maxine877, Location: UK PostPosted: Thu Apr 14, 2011 3:00 am
    ----
turns over but the engines not kicking in. omg i think i may have killed it. r.i.p pug Sad

#23: Re: indicators 206 1.1 Author: Lee, Location: England PostPosted: Thu Apr 14, 2011 2:27 pm
    ----
Make sure you've onnected the immobliser back up

#24: Re: indicators 206 1.1 Author: maxine877, Location: UK PostPosted: Thu Apr 14, 2011 2:46 pm
    ----
what does it look like so i know that i have??

#25: Re: indicators 206 1.1 Author: Lee, Location: England PostPosted: Thu Apr 14, 2011 2:53 pm
    ----
Just make sure you've plugged all the wires in right

#26: Re: indicators 206 1.1 Author: maxine877, Location: UK PostPosted: Thu Apr 14, 2011 3:09 pm
    ----
right i have checked all the wires. now what ?? its still not working Sad

#27: Re: indicators 206 1.1 Author: maxine877, Location: UK PostPosted: Sat Apr 16, 2011 4:24 am
    ----
right it doesnt fire, the right indicator works and so do the hazards but now the left wont do anything no clicking or lights, but it does work as a hazard??

#28: Re: indicators 206 1.1 Author: maxine877, Location: UK PostPosted: Thu Apr 21, 2011 5:19 pm
    ----
hi

just to let you know i di exactly as you guys sed and pulled out the bsi and stalks. i dusted it all and put it back in while i shopped for relays. it has started to work again. probably means am gonna have to do this every week. silly thing. only my radio wont work?? it wont switch on or anything, at least before half way through your journey it used to spring into life all of sudden. now it does nothing?? any more ideas.



-> 206 Problems


Page 1 of 1
 
We are not responsible for comments posted by our users, as they are the property of the poster
Interactive software released under GNU GPL, Code Credits, Privacy Policy