New Here?
Toggle Content
   

Toggle Content User Info
Welcome

Anonymous

Nickname
Password
Register

Membership:
Latest: Hammondyouidiot
New Today: 1
New Yesterday: 0
Overall: 16877

Online Now [18]:
Visitors: 18
Bots: 0
Members: 0
Staff Online Now:

No staff members are online!
Page Views:
Today: 9539
Total: 74856985

Toggle Content Main Menu
 General Info Goodies Search Web Stats Members
 Donations

 

Forums › The Car › 206 Problems › Non-starter 1.4 HDi: mechanical vs electrical


 
 

Non-starter 1.4 HDi: mechanical vs electrical
Forum Index206 Problems
Reply to topic Printer Friendly Page watchs.gif View Previous Topic View Next Topic
Author
Message
Sim
PostPosted: Sun Mar 22, 2020 11:48 pm Up
206 Crazy


Offline

Joined: Jun 20, 2012
Posts: 1057
Trade Rating: +1
Location: West Country


Hey all,

Contrary what I said in the shoutblock, the 2002 £50 runabout hasn't completely recovered from the dead yet.

Albeit managed to start it couple of times earlier this month, lately it's only been spinning the starter.

Immobiliser status (beep test passed):
ECU:
Unit control condition: ECU locked
Status of the coded engine immobilizer programming: matched ECU
Problems detected when transmitting the unlock code: awaiting response from BSI

BSI:
Number of keys learned: 1
Transponder code recognised: yes (changes consistent with beep test)
BSI matched: yes
Key in the ignition position: yes
Engine control unit locked: yes

The relay in the engine fusebox is clicking, there are 0.5-1Amps going through the fuse F8 when ignition is on.

I've done a myriad of tests, from wire tracing, to fuel pressure and injector leak-off. Headbutting the wall at the moment Wall Bang

Best is if you ask what tests should be run, and I'm pretty sure I'll have the outcome readily Smile

Here's the list of ECU faults (that fail to clear for some reason), the first one being the prime suspect, as I think all the rest should not cause a non-start condition/locked ECU, as per online researches:

Multiplexing No communication with the BSI
P0483 Engine cooling function integrated into the engine control unit Open circuit or actuator malfunction
P0183 Diesel temperature signal Open circuit or short circuit to +ve
P0313 Clutch switch signal Consistency with vehicle speed
P3007 Flowmeter signal Low air flow sensor signal (due to airbox removed)
P1505 Impact detection Impact information sent by the air bag
P0221 Accelerator pedal signal 1 fault. Consistency with accelerator pedal signal 2
P0382 Preheating relay circuit fault. Plugs permanently supplied
P0226 Accelerator pedal signal 2 fault. Consistency with accelerator pedal signal 1
P0342 Camshaft Position Sensor "A" Circuit Low DTC (yet cam/crank sync says yes during test data)
Airbag ECU:
Remote intermittent fault. Vehicle speed information


Cheers4help!
Sim

2.0 HDi, year 2000 (lockdown beater, back on Andrew's Toyos!)
GTi 180, year 2004 (in hibernation after endless driving fun in 2019, queued for "cambelt in tight spaces")
Missus' 1.6 16v CC, year 2007 (rear quarter reweld WIP)
£50 1.4 HDi, year 2002 (endless false positives due to one fault masking another, but all sorted now!)
..couple more Franco/American-made/owned ones, journey depending
View user's profile
VorTechS
PostPosted: Mon Apr 27, 2020 2:15 pm Up
Staff - Vortechs


Offline

Joined: Feb 08, 2010
Posts: 2354
Trade Rating: +15
Location: Gloucestershire, UK


I'd have thought:

P1505 Impact detection Impact information sent by the air bag

...would prevent a start....?

 

View user's profile
Sim
PostPosted: Tue Apr 28, 2020 11:56 am Up
206 Crazy


Offline

Joined: Jun 20, 2012
Posts: 1057
Trade Rating: +1
Location: West Country


I thought so too, but the car had started a couple of times and that error had already been present.

Also confirmations that P1505 doesn't cause non-start: here, here, and here.

Got the MPPS kit as per pro_steve's instructions on hdi-tuning.co.uk, will obtain the ECU firmware dump and take it from there.

2.0 HDi, year 2000 (lockdown beater, back on Andrew's Toyos!)
GTi 180, year 2004 (in hibernation after endless driving fun in 2019, queued for "cambelt in tight spaces")
Missus' 1.6 16v CC, year 2007 (rear quarter reweld WIP)
£50 1.4 HDi, year 2002 (endless false positives due to one fault masking another, but all sorted now!)
..couple more Franco/American-made/owned ones, journey depending
View user's profile
Sim
PostPosted: Sat May 16, 2020 1:38 pm Up
206 Crazy


Offline

Joined: Jun 20, 2012
Posts: 1057
Trade Rating: +1
Location: West Country


Update: MPPS could not read off the ECU firmware dump, and it failed to do so with both original BSI+ECU set, and a replacement BSI+ECU set (which are from a newer 1.4 HDi model with DPF/FAP, but it should still perform the read as the latter pair is in known working order).

Conclusion: original ECU is healthy, and the problem is in the wiring loom or in one of the sensors/components jamming the CAN bus or shorting some circuit. As you can see from the faults list there are a couple of offenders - engine cooling, diesel temperature, and preheating relay. Unsure which one's the cause, and which others are only the effect of it.

So next up will be to disconnect those components and see if I can get me an ECU comms back.

PS: the tooling itself is sound: I managed to read off the ECU contents from the other car just fine (2.0 HDi)

2.0 HDi, year 2000 (lockdown beater, back on Andrew's Toyos!)
GTi 180, year 2004 (in hibernation after endless driving fun in 2019, queued for "cambelt in tight spaces")
Missus' 1.6 16v CC, year 2007 (rear quarter reweld WIP)
£50 1.4 HDi, year 2002 (endless false positives due to one fault masking another, but all sorted now!)
..couple more Franco/American-made/owned ones, journey depending
View user's profile
gazza82
PostPosted: Mon May 18, 2020 9:46 am Up
206 Crazy


Offline

Joined: Jun 19, 2010
Posts: 1555
Trade Rating: +3
Location: South Bucks


I found the glow-plug relay would throw up odd errors when mine failed on our 1.4hdi .. might be worth starting there!
Down to just the 1.4 HDi. Cayman Green 2.0i CC sold.
View user's profile Visit poster's website
Sim
PostPosted: Sat Jun 06, 2020 3:28 pm Up
206 Crazy


Offline

Joined: Jun 20, 2012
Posts: 1057
Trade Rating: +1
Location: West Country


tl;dr car's alive! (queue the line from the Frankenstein)

Thanks gazza82, I've been reading that glowplugs barely ever come on on the common-rail diesels, so I unplugged the relay and supply altogether whilst "eliminating" bad wiring suspects.

Little did I know that an unplugged glowplug relay causes limp home mode, which the car went into after I started it successfully when reflashing ECU with an immo-off EEPROM.

So the car ran fine, re-plugged relay brought it out of limp home mode as well.

The only problem I was left with is the dreaded ECU and BSI fault respectively:
Multiplexing No communication with the BSI
Permanent fault. Absence of communication with the engine management ECU.

Which resulted in a dead dashboard: no wipers/lights/speedo/RPM/temp gauges.

After lots of huffing and puffing I finally found that dashboard comes into life and all those faults go away after moving the pair of twisted CAN wires short of the black 40-way BSI connector. I think that was the one and only issue all along.

I'll do more in-depth load testing (with some 40W light bulb), then replace the damaged wiring portion and see if it permanently brings things back to normal, I'll also reflash the original EEPROM with the immobiliser back on.

There's still no clear cut explanation, as I had weird false-positive readings when I first (and numerous times after) tested the CAN bus for continuity, but one thing's for sure: the car will be back on the road soon Thumbs Up

2.0 HDi, year 2000 (lockdown beater, back on Andrew's Toyos!)
GTi 180, year 2004 (in hibernation after endless driving fun in 2019, queued for "cambelt in tight spaces")
Missus' 1.6 16v CC, year 2007 (rear quarter reweld WIP)
£50 1.4 HDi, year 2002 (endless false positives due to one fault masking another, but all sorted now!)
..couple more Franco/American-made/owned ones, journey depending
View user's profile
gazza82
PostPosted: Sun Jun 07, 2020 9:45 am Up
206 Crazy


Offline

Joined: Jun 19, 2010
Posts: 1555
Trade Rating: +3
Location: South Bucks


Not your issue but another problem with the 1.4 hdi is the cat. We kept loosing power ... usually on a motorway, going uphill with an artic up our chuff!!!

Turned out the cat had collapsed and the smaller ball it formed was blocking the exhaust if it rolled a certain way ... must have overheated (or sh*te supermarket diesel) ...

A bit hammer and long steel bar sorted that ... nothing to block it now!!!

Down to just the 1.4 HDi. Cayman Green 2.0i CC sold.
View user's profile Visit poster's website
ekjdm14
PostPosted: Sun Jun 07, 2020 12:07 pm Up
Full on 206 Owner


Offline

Joined: Jan 06, 2020
Posts: 165
Trade Rating: 0
Location: Cheshire


Agreed, SWMBO's 1.4HDi had the beginnings of the cat disintegrating when I pulled the head for the glowplug fiasco (not quite as bad as yours it had about an inch side to side, but I imagine once the brick becomes loose it's rate of demise is exponential due to the extra room it makes for itself to rattle around).

Needless to say, it met the same fate as yours Gazza. This was about 96k, what mileage was yours on?

The 1.4HDi parts car we got to rebuild the rear quarter of the 1.4i had a very shiny new looking cat on it too and that was on IIRC 104k so maybe a common issue round the 100k mark?

Not so bad really, as these little motors will p1ss emissions without it anyway as long as the shell is there and uncut, and no EGR... I'd have to say looking at the figures, if one of these fails emissions there's something major wrong!

'02 1.4HDi Mercury Grey 102k (waiting for it's time to shine once more)
'03 GTi 180 Aegean Blue 92k (suffering gearbox/diff issues)
'03 Obsidian Black XUD9TE/veg fuelled b-road toy (waiting on new turbo)

+'95 Citroen Xantia 1.9D auto (on loan to inlaws)
+'99 306 2.0SE cabriolet
+'97 306 1.9LXDT
French Car Forums
View user's profile
gazza82
PostPosted: Sun Jun 07, 2020 4:31 pm Up
206 Crazy


Offline

Joined: Jun 19, 2010
Posts: 1555
Trade Rating: +3
Location: South Bucks


ekjdm14 wrote:
Needless to say, it met the same fate as yours Gazza. This was about 96k, what mileage was yours on?

The 1.4HDi parts car we got to rebuild the rear quarter of the 1.4i had a very shiny new looking cat on it too and that was on IIRC 104k so maybe a common issue round the 100k mark?

Can't remember the exact mileage but high 80s rings a bell.

ekjdm14 wrote:
Not so bad really, as these little motors will p1ss emissions without it anyway as long as the shell is there and uncut, and no EGR... I'd have to say looking at the figures, if one of these fails emissions there's something major wrong!

It's been through a couple cat-less with no internals but EGR is still there ... the last fail was the rear brake load sensor ... and I have feeling that had been stuck for a while ... Wink A few squirts of a good penetrating fluid, some "whiggling" and a heavy coating of white grease sorted that one ...

Down to just the 1.4 HDi. Cayman Green 2.0i CC sold.
View user's profile Visit poster's website
ekjdm14
PostPosted: Sun Jun 07, 2020 10:04 pm Up
Full on 206 Owner


Offline

Joined: Jan 06, 2020
Posts: 165
Trade Rating: 0
Location: Cheshire


Yeh I could've worded that better, I mean they'll pass with both gutted cat AND no EGR (guess it read like I was suggesting they needed the EGR f*cked off in order to pass!)

Ours has done 2 or 3 tests with cat gutted and EGR blocked and always comes back ridiculously low compared to what's allowed. Can't remember exact numbers but seem to recall it was in the order of under 1/10th of what's allowed in all areas so you'd have to have a really ill motor/oily turbo for it to fail really.

The MoT bogey on ours has always been rear brake related too, couple of times handbrake not strong enough & couple of times the compensator valve too. (I do have a complete ABS setup except for front sensors though, from a parts car & always thought I might do that one day and be rid of the comp valve. Have already sacked off the "auto" adjuster part of things as that kept causing problems & once they're set let's face it, a 1.4HDi Style ain't going to be going through much rear shoe in under 5k/year!

'02 1.4HDi Mercury Grey 102k (waiting for it's time to shine once more)
'03 GTi 180 Aegean Blue 92k (suffering gearbox/diff issues)
'03 Obsidian Black XUD9TE/veg fuelled b-road toy (waiting on new turbo)

+'95 Citroen Xantia 1.9D auto (on loan to inlaws)
+'99 306 2.0SE cabriolet
+'97 306 1.9LXDT
French Car Forums
View user's profile
gazza82
PostPosted: Mon Jun 08, 2020 8:03 am Up
206 Crazy


Offline

Joined: Jun 19, 2010
Posts: 1555
Trade Rating: +3
Location: South Bucks


On mine it screwed the braking and the rears locked up early!!
Down to just the 1.4 HDi. Cayman Green 2.0i CC sold.
View user's profile Visit poster's website
ekjdm14
PostPosted: Tue Jun 09, 2020 10:35 pm Up
Full on 206 Owner


Offline

Joined: Jan 06, 2020
Posts: 165
Trade Rating: 0
Location: Cheshire


Haha had that issue after we first dropped the beam on ours, my calculations for readjusting it were a bit off and it must have thought there was an elephant in the boot!
'02 1.4HDi Mercury Grey 102k (waiting for it's time to shine once more)
'03 GTi 180 Aegean Blue 92k (suffering gearbox/diff issues)
'03 Obsidian Black XUD9TE/veg fuelled b-road toy (waiting on new turbo)

+'95 Citroen Xantia 1.9D auto (on loan to inlaws)
+'99 306 2.0SE cabriolet
+'97 306 1.9LXDT
French Car Forums
View user's profile
Reply to topic Printer Friendly Page watchs.gif View Previous Topic View Next Topic All times are GMT
Forum Index206 Problems

Page 1 of 1
  You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum

 
We are not responsible for comments posted by our users, as they are the property of the poster
Interactive software released under GNU GPL, Code Credits, Privacy Policy